Oly EPL3: загадочное поведение в насыщении

Есть у меня Oly E-PL3, который я использую как мыльницу (с набором фикс-оптики). И угораздило меня летом попытаться снять для нее кадры для Time-Lapse.

Вот, наконец, дошли руки, стал смотреть эти кадры и вижу там удивительное:

Ну то есть да, обычные розовые облака, но если посмотреть гистограмму серого квадратика на розовом, то там вовсе безумно странное:
Никакого тебе насыщения ни в одном из каналов, красный и синий - сильнее зеленого, сплошные чудеса.

Ого, думаю. "Никогда такого не было и вдруг опять". Вроде нормальное насыщение было у камеры.

Взял ту же камеру, тот же объектив, то же значение ISO и вот прямо видное из окна того. Чтобы получить пересвет, пришлось +2 компенсацию поставить:

Смотрим на гистограмму, никаких ужасов нет, все как ожидалось, пик в нужном месте:

Какие идеи? У меня - две:

  • Либо камера начинает себя неадекватно вести при перегреве (потому что почти 1000 кадров сняла, по 5 кадров в минуту)
  • Либо камера начинает себя неадекватно вести при разряде аккумулятора (эти 1000 кадров - это три полных батарейки)
Обе гипотезы буду изучать, а пока напомню про свой любимый лозунг знай свою камеру.

Comments

Интересно, в этом фото http://raw-rpp.livejournal.com/129669.html не аналогичная ли ситуация?

Скачал. Не, там нормальные такие "пики на полке"

Розовая область на первом кадре выглядит однородной весьма (хотя зум не помешал бы), а на гистограмме нормальный такой разброс.

Может баг диггера?
Другими инструмантами попробовать, РПП тот же в режиме RAW

Она однородная если издалека.

А на самом деле - нет, там разброс в ~1/4 стопа (который виден особо не будет в таком виде), если поставить уровень черного в ~3300, то видно прекрасно.

"Другие инструменты" в виде ACR - если поднять контраст в светах, показывают там структуру. Как и RawDigger.

Предположу, что есть не один тип насыщения, а (как минимум) три. Насыщение по заполнению светочувствительной ячейки электронами, насыщение по достижению максимального уровня усиленного сигнала с матрицы, и насыщение по исчерпанию разрядной сетки АЦП (или последующего за ним DSP и т.д.). Насыщение ячеек не может давать ровной полки по той причине, что емкость ячеек отличается от ячейки к ячейке. В зависимости от стабильности техпроцесса в насыщенном состоянии они, усредненно, должны давать более или менее узкий колокол. Насыщение по достижению максимального уровня аналогового сигнала после усилителя должно давать узкий (возможно, даже единичной ширины) пик, ширину которого определяет временнАя нестабильность усилителя (и питающего его напряжения) и нестабильность АЦП. Насыщение по исчерпанию разрядной сетки (либо любого искусственного цифрового порога) должно давать пик единичной ширины. Какой из них наступает раньше? Полагаю, что может случиться по-разному. В зависимости от коэффициента усиления (ISO), от температуры сенсора, от напряжения питания.

Замечу что
а) камера одна и та же
б) температура - близкая
в) ISO - одно

Т.е. есть гипотезы про "перегрев" и про батарею, я их вечером поставлю проверяться (снимать что-то яркое...)

Занятно. Ни разу не сталкивался, но я своим e-pl3 time-lapse и не снимал никогда.

Есть еще гипотеза, что при солнце в кадре начинаются странности.
Но я снял сейчас десяток кадров - вроде нет такого, ни на первом, ни на десятом.

Снимал, правда, через стекло, яркость не та.

Летом снимал всякое, в т.ч. и с солнцем в кадре под открытым небом, но такого эффекта не возникало.

может глюк в коде raw digger'а ?

Да как-то маловероятно.

я наверно ниразу непонял, но розовое-то рисует код в одном месте и код же не видит клиппинга на гистограмме ? как так вышло ?

Клипинга на гистограмме - нет.
А розовое - оттого, что после ББ зеленый оказывается самым слабым.

"Детали" (очень неконтрастные) в этом розовом пятне очень даже есть.

У Nikon D4 - одной из 2 - та же болячка, причем она видна в Nikon SDK

Нелинейность сенсора в светах + разная поканальная чувствительность?
Где то в глубинах сети попадалось про кривой синий канал на олимпусах.

Ну вот второй кадр (зимний пейзаж с +2) не имеет же этой проблемы?
Сегодня снял еще солнце в кадре - там тоже полка, как и ожидалось.

Я не про клиппинг. Его не видно на гистограммах. Я про загиб кривых in->out. А тут еще и зимний день с летним синим вечером. Уровни синего канала разные на гистограммах. Но это только предположения.

придется камеру греть грелкой с кипятком перед съемкой !

Наблюдал у себя на зеркалке такой "глюк"....Но - розовое было только в редакторе Rawtherapee, при неосторожном обращении с экспозицией - в других конвертерах все ок. Имхо - баг исключительно в конвертере raw->jpeg.

тайна розовых облаков - проблема известная и связанная с тем, что Raw-конвертор имеет неправильное представление о реальных максимумах данных.

В ситуации, когда максимум ползет в процессе съемки (о чем данный пост и два следующих) - правильного представления у конвертора и не может быть.

There is the same gaussian highlights phenomenon with Canon 6D (and perhaps every Canon) on long exposures with exposure of >=1sec but not on shots with "XNR" notation where there is a clear clipping point. Do "XNR" means "without noise reduction ??
Camera temp looks normal according to exifs, around 25C.
Sensor saturation cannot be the cause because it happens even for ISO200-400 ... DAC saturation maybe ??.
White point is at 13390 normally (when it's a single clipping point) but when there is this "gaussian" distribution it should be a bit lower down to about 13300.
After converting to DNG Adobe sets WP at 15000-2048=12952 to be on the safe side I suppose.

http://216.18.212.226/PRODS/canon-6d/FULLRES/E6DLL0001007.CR2
http://216.18.212.226/PRODS/canon-6d/FULLRES/E6DLL0001007XNR.CR2

http://216.18.212.226/PRODS/canon-6d/FULLRES/E6DLL0002007.CR2
http://216.18.212.226/PRODS/canon-6d/FULLRES/E6DLL0002007XNR.CR2

Yes, the difference is very clear.

The strange thing is EXIF data for these shots. I've run exiftool -v -v on two last files, than compare the results. No differences regarding 'Noise Reduction' settings.

What is XNR mark really?

In fact it's the inverse than I thought, stdev is less for XNR shots both on side black zone and on the black patch of cc24 that I tryied. This for Canon 6D and 600D that I checked.

I also checked Panasonic GH-3. There XNR shots are more noisy than not XNR ..

We have to ask Imaging Resource what the meaning of XNR is ..

According to IR 5DMkII page, XNR corresponds to long exposure NR set to Off.

In samples you've posted:
XNR ones have 1-value wide histogram in blown highlights
no XNR have bell-curve like histogram at extreme right

I guess this is caused by dark frame subtraction procedure:
step1: shot processed by ADC with 1-value wide peak on extreme right
step2: dark frame (with pixel variations) subtracted, producing variations on extreme right

Indeed, black frame subtraction sounds the as the most possible reason.
It even explaines the increased stdev for the nonXNR shots as measured on the optically black pixels .. ISO100, XNR 4.9 - nonXNR 6.9 exactly the expected sqrt(2) ratio !!.

But I couldn't imagine that it affects so much the highlights !!.

Here is histogram of blown highlight on bell on ..02007.CR2 file:
The highlights are not *affected much*, the gauss-like curve is only ~30 levels wide (of 13400 full range). This is 30/6700=0.004 ~ 1/16EV. Nothing to worry about.

1/256EV, not 1/16.

No worries for sure. I'm just saying that my brain fall short to understand it at first sight:).

Do you think that there is any correlation with EPL-3 samples. For example it could be dark signal subtraction as it happens in CMOS sensors with Correlated Double Sampling .. If the remaining electrons after reset is increasing shot after shot, CDS would subtract more and more from the signal ...

It needs more accurate testing. Something like Q13 grayscale with stable lighting to check sensor linearity plus bright LED lamp for overexposed highlights.

Regardless of testing results, the conclusion is already known: long time-lapse sequences with sun in frame cannot be shot with EPL3. No problems without direct sun.

Add new comment