Qt licensing - 2

Нам пишуть:

Dear Qt User:
Nokia is pleased to announce that with the release of Qt 4.5 you will be able to use Qt under the Lesser General Public License (LGPL) version 2.1 terms. When released in March 2009, Qt will be made available under three licensing options: Commercial, LGPL and GPL. Prior versions of Qt are not impacted by this announcement.

Спасибо компании Nokia за поэкономленные 5 килобаксофф (скидки для Small business/Startup они отменили осенью)

Comments

Что умиляет, это вот эти гениальные оговорки про Prior versions of Qt are not impacted by this announcement. Я тут, некоторым образом, по причине некрофилии о которой напишу отдельно, столкнулся с необходимостью иметь коня, т.е. motif 1.2 на доисторической платформе, just for fun. Дык, натурально, пришлось стать конем самому, то есть с помощью напильника и какой-то матери собрать вполне себе последний lesstif через жопу автогеном - потому как OSF сотоварищи мало что сделали 1.2 "not impacted by this announcement" - они еще судя по слабому попукиванию на prnewswire еще и пытаются впаривать этот доисторический ужас разным жертвам embedded development за вполне реальные бабки. Препятствуют, понимаешь, проникновению в массы технологий каменного века, мешают испытать экстаз от оригинального трупа образца 94 года..

Там могут быть просто юридические проблемы, которые мешают это сделать.

Ну там лицензировали что-то у кого-то на тех условиях или приняли какие-то патчи от третьих лиц и все, это же надо какую кучу бумаги исписать, чтобы поправить.

Сильный ход, да. Вот небось народу обидно, кто купил по полной цене в этом году.

народу, ишь!

Я уже кредитной карточкой замахнулся. Хорошо что у них сейлзы такие медлительные...

Add new comment