Мизантропическое

Голосом зануды:
MovableType 4.x. Казалось бы, давно имеем систему Widget Set, можно собрать сайдбар из этих самых виджетов мышкой и разместить в блоге. Прекрасная штука, была еще в 3-й версии.
Однако в 4-й версии про них явно забыли и включаемые элементы настраиваются переменными (по сути, дефайнами) в шапке страницы. Как-то так:
<MTSetVar name="sidebar" value="1">
<MTSetVar name="module_recent_entries" value="1">
<MTSetVar name="module_category_archives" value="1">
Ну скажите пожалуйста, если widget set - это плохо, то нафига для них отдельный пункт меню завели ? При этом, естественно, набор переменных новых темплейтов в документации не описан, несмотря на то, что одно из ключевых Release Notes у четверки озвучено как Kick-ass documentation. Впрочем, если kick-ass переводить буквально, то ощущение от документации сходится. Попробуйте там найти что-нибудь действительно нетривиальное....

MT-Colorer. Кажется прекрасной заменой для кривого, косого и т.п MTCodeBeautifier-а (который, извините уже непонятно как скачать, хорошо что в заначке был).
Но он тянет за собой ports/devel/colorer, который в свою очередь хочет принести все известные ему библиотеки и компиляторы java, после чего все ломается. Видите-ли JDK 1.4 не собирается GCC 4.2, а у меня это, пардон, системный компилятор (FreeBSD-current) и другого тут не носят.

Эх, хорошо что я незлобивый. Другой бы давно всех убил, один бы остался. (С) Успенский, близко к тексту.

Comments

Разве в тройке есть таскабельные мышкой виджеты? Где они тут?

У меня тройки уже не осталось под руками, но есть.

Там в разделе Templates есть линк "create new widget template" и, соответственно, можно ими как-то управлять.

У меня вот прямо в этом блоге (пока он был на тройке, но и на 4-ке соответственно тоже) сайдбар сделан именно так.

А в 4-ке их вытащили еще больше наружу, но стандартный Template Set их не использует. Дурдом.

О, нашел упоминание в доке на 3.3, там все написано

http://www.sixapart.com/movabletype/docs/3.3/k_preinstalled_plugins/widg...

Спасибо большое!

Оказывается, WidgetManager забандлили в 3.3, на которую я заленился в своё время переползать.

Add new comment